Searching for some series returns 404 no result

A place for developers to advertise their TheTVDB.com enabled app and get help from other developers with the API.
Post Reply
TonioNDS
Posts: 1
Joined: Thu Feb 01, 2018 11:25 am

Thu Feb 01, 2018 11:35 am

Hi!

I just got an API key and I'm trying to get some information about a few series/animes, as a test, and some of them are not found when searching for an ID, even though other series work fine:
The Vampire Diaries
Lucifer
The Big Bang Theory

The Good Doctor
Fate/Zero (Note: looking for "Fate Zero" returns 404...)
Fate/Stay Night (Note: looking for "Fate Stay Night" returns 200!)
Naruto

I've checked, and all of those series/animes exist within TheTvDB, and have an ID, so... They SHOULD appear in the search request results, right?

Does anyone have any idea on what the problem might be?
I'll share my code if needed, though I don't think it is related, since most of the series work fine...

Thank you!
HairyJohn
Posts: 8
Joined: Mon Apr 02, 2018 1:52 pm

Mon Apr 02, 2018 2:21 pm

Hi, I am seeing the same thing. For example:
https://api.thetvdb.com/search/series?name=luc returns a 404, but
https://api.thetvdb.com/search/series?name=lucifer works.

Is this something the developers are aware of?

Thanks
John
HairyJohn
Posts: 8
Joined: Mon Apr 02, 2018 1:52 pm

Fri Apr 06, 2018 12:34 am

Actually ignore my post, I have come to realise that search is on whole words only, not partial.
It threw me that when the search fails to find a match it throws a 404. I would expect a 200 with an empty array.
Post Reply