Ongoing Issues: XML

Series that require continual maintenance and / or aggressive cleanup.
Lothian
Posts: 3
Joined: Tue Nov 18, 2014 7:28 am

Doctor Who (2005) XML error on access from FileBot

Postby Lothian » Mon May 22, 2017 6:21 am

I am not sure if this is really a TVDB problem or a FileBot problem. But when I tried to use FileBot to look up an episode for Doctor Who (2005), I received an error message "Invalid XML: SAXParseException: The element type "DVD_episodenumber" must be terminated by the matching end-tag "</DVD_episodenumber>".

I do not receive this for any other series, this makes me think that TheTVDB is sending an incorrect XML entry to FileBot, however I do not know the details of this interface and it is possible that it is FileBot making up the XML message based on data it receives in another way from TheTVDB.

Has anybody else encountered this problem?

Thanks

DarklightIndigo
Just zis guy, you know?
Posts: 7642
Joined: Sun Apr 27, 2014 9:16 am
Location: San Francisco
Contact:

Re: Doctor Who (2005) XML error on access from FileBot

Postby DarklightIndigo » Mon May 22, 2017 7:28 am

Do you happen to know what episode is returning this error?
I've seen malformed entries do this before, but it'd help to narrow it down.
Strangers are just the friends we haven't met yet.

19fox86
Posts: 5
Joined: Mon May 22, 2017 9:48 am

Re: Doctor Who (2005) XML error on access from FileBot

Postby 19fox86 » Mon May 22, 2017 9:55 am

I have encountered the same error but with 12 monkeys season 03.~
The only diference is that in my case is the EpisodeName.
Also I'm having trouble with metax finding the latest episodes for various tv shows wich leads me to believe the problem is with TVDB.

DarklightIndigo
Just zis guy, you know?
Posts: 7642
Joined: Sun Apr 27, 2014 9:16 am
Location: San Francisco
Contact:

Re: Doctor Who (2005) XML error on access from FileBot

Postby DarklightIndigo » Mon May 22, 2017 11:37 am

19fox86: I found a malformed image in S03E09, it's possible this is related.
Please re-scrape S03 and let me know if anything changes.
(Note that if you're using Plex, their cache updates once per day, so you'll want to check again in 24 hours).
Strangers are just the friends we haven't met yet.

19fox86
Posts: 5
Joined: Mon May 22, 2017 9:48 am

Re: Doctor Who (2005) XML error on access from FileBot

Postby 19fox86 » Mon May 22, 2017 1:45 pm

No. Still having the same error with filebot.
I've tried with all files on Season 03 of 12 Monkeys (All 10 episodes) individually and they all return the same error on the EpisodeName.
Invalid XML: SAXParseException: The element type "EpisodeName" must be erminated by the matching end-tag "</EpisodeName".

DarklightIndigo
Just zis guy, you know?
Posts: 7642
Joined: Sun Apr 27, 2014 9:16 am
Location: San Francisco
Contact:

Re: Doctor Who (2005) XML error on access from FileBot

Postby DarklightIndigo » Mon May 22, 2017 2:21 pm

Hrm... okay, I'm not positive how the XML generation works, but I believe it's refreshed when entries are saved, so I've tried re-saving the entries in question (though the change may take time to propagate).

Just to verify, this was the English listings, correct?
Strangers are just the friends we haven't met yet.

kimmo
Posts: 6
Joined: Sun Mar 06, 2016 6:17 pm

Re: Doctor Who (2005) XML error on access from FileBot

Postby kimmo » Mon May 22, 2017 2:48 pm

XML Parsing Error: unclosed token
Location: http://thetvdb.com/api/YOUR_KEY_HERE/se ... all/en.xml
Line Number 603, Column 15: <EpImgFlag>2</EpI
--------------^

AND

XML Parsing Error: unclosed token
Location: http://thetvdb.com/api/YOUR_KEY_HERE/se ... all/en.xml
Line Number 679, Column 30: <Combined_episodenumber>1.0</Combined_ep
-----------------------------^

AND

XML Parsing Error: unclosed token
Location: http://thetvdb.com/api/YOUR_KEY_HERE/se ... all/en.xml
Line Number 911, Column 20: <thumb_height>225</
-------------------^

AND

XML Parsing Error: no root element found
Location: http://thetvdb.com/api/YOUR_KEY_HERE/se ... all/en.xml
Line Number 11043, Column 484:

19fox86
Posts: 5
Joined: Mon May 22, 2017 9:48 am

Re: Doctor Who (2005) XML error on access from FileBot

Postby 19fox86 » Mon May 22, 2017 3:52 pm

Correct, english listing.
I will try again tomorrow.
Thanks for the help

kimmo
Posts: 6
Joined: Sun Mar 06, 2016 6:17 pm

Re: Doctor Who (2005) XML error on access from FileBot

Postby kimmo » Mon May 22, 2017 5:16 pm

the above is fixed, but there are more...
e.g.
viewtopic.php?f=17&t=37586
XML Parsing Error: unclosed token
Location: http://thetvdb.com/api/YOUR_KEY_HERE/se ... all/en.xml
Line Number 1415, Column 3: <Directo
--^

and probably a lot more...

the big change was max 1-3 days ago... maybe restore data from the zip files, that seem to be ok

kimmo
Posts: 6
Joined: Sun Mar 06, 2016 6:17 pm

Re: Doctor Who (2005) XML error on access from FileBot

Postby kimmo » Mon May 22, 2017 5:44 pm

and more...
id's:
279121
267440
274431

how to test:
try http://thetvdb.com/api/YOUR_KEY_HERE/series/281623/all (without the e.g. "en.xml")
this look like is defaults to English ?

But if there is and error it will show the list of all the languages like this:

"Parent Directory -
[ ] cs.xml 22-May-2017 12:10 56K
[ ] da.xml 22-May-2017 12:10 56K
[ ] de.xml 22-May-2017 12:10 56K
[ ] el.xml 22-May-2017 12:10 56K
[ ] en.xml 22-May-2017 12:10 56K
...

Apache/2.2.22 (Ubuntu) Server at http://www.thetvdb.com Port 80"