V3 /movieupdates always returns 401

A place for developers to advertise their TheTVDB.com enabled app and get help from other developers with the API.
Post Reply
roign
Posts: 6
Joined: Thu Nov 07, 2019 4:39 am

Tue Jan 21, 2020 8:55 am

Trying to request the new /movieupdates endpoint always returns 401 responses, even when the token is valid and usable with other endpoints.

A request to https://api.thetvdb.com/movieupdates?since=1579606098 returns:

Code: Select all

{
  "Error": "Not authorized"
}
and a 401 status.

It seems to be a bug as far as I can tell.
ChristyEzzell
Posts: 1110
Joined: Tue Feb 26, 2019 12:01 pm

Wed Jan 22, 2020 10:51 am

roign wrote:
Tue Jan 21, 2020 8:55 am
Trying to request the new /movieupdates endpoint always returns 401 responses, even when the token is valid and usable with other endpoints.

A request to https://api.thetvdb.com/movieupdates?since=1579606098 returns:

Code: Select all

{
  "Error": "Not authorized"
}
and a 401 status.

It seems to be a bug as far as I can tell.
Thanks for reporting. We are investigating this.
tommboys
Posts: 28
Joined: Fri Nov 08, 2019 2:25 pm

Wed Jan 22, 2020 2:31 pm

And I keep getting them when i'm trying to get show info. Can you guys please fix whatever's causing all these problems.
ChristyEzzell
Posts: 1110
Joined: Tue Feb 26, 2019 12:01 pm

Wed Jan 22, 2020 3:55 pm

tommboys wrote:
Wed Jan 22, 2020 2:31 pm
And I keep getting them when i'm trying to get show info. Can you guys please fix whatever's causing all these problems.
Is it the same error on the TV shows? Not Authorized? They are different endpoints so any additional information would help. You are the first report of this problem.
tommboys
Posts: 28
Joined: Fri Nov 08, 2019 2:25 pm

Wed Jan 22, 2020 4:50 pm

it's a 401 error. i never got them in the past. it's been working and not working for the past week or two, but mostly not working. it's whenever i try to find episode info for tv shows
ChristyEzzell
Posts: 1110
Joined: Tue Feb 26, 2019 12:01 pm

Tue Feb 04, 2020 2:13 pm

tommboys wrote:
Wed Jan 22, 2020 4:50 pm
it's a 401 error. i never got them in the past. it's been working and not working for the past week or two, but mostly not working. it's whenever i try to find episode info for tv shows
We tried duplicating this on both TV and movies. On TV shows, we could not find an issue. For movies, we were missing a lambda authorizer, which we have now added.
roign
Posts: 6
Joined: Thu Nov 07, 2019 4:39 am

Wed Feb 05, 2020 9:22 am

ChristyEzzell wrote:
Tue Feb 04, 2020 2:13 pm
We tried duplicating this on both TV and movies. On TV shows, we could not find an issue. For movies, we were missing a lambda authorizer, which we have now added.
It is now working. Thank you!
Post Reply