V3 Testing

A place for developers to advertise their TheTVDB.com enabled app and get help from other developers with the API.
TheRealHagnar
Posts: 1
Joined: Sat Nov 16, 2019 1:19 pm

Sat Nov 16, 2019 1:25 pm

I have noticed that searching a series by IMDB ID responsed back with "Resource not Found" and a 404 error. This looks to happen with any IMDB ID search as I have not found a working on yet.

Example: Postman call to the /search/series endpoint. IMDB ID being used in the example is tt8111088 (The Mandalorian)

Image
dlflannery
Posts: 35
Joined: Sat Oct 16, 2010 8:27 am
Location: Southwest Ohio, USA

Sun Nov 17, 2019 12:56 am

Can someone tell me how to be sure I'm testing the V3 API in the app I program? Here are possible options I've seen on the forum or in the API documentation:

1. Use api-beta.thetvdb.com
2. Put Accept:application/vnd.thetvdb.v$VERSION. in the headers
3. api.thetvdb.com now defaults to V3

Which or what combination of these gets me to V3?

I would note that I've tried almost every combination of these and they all exhibit the issue that the series/{id} endpoint doesn't work even with a known correct value of id.
mrtn
Posts: 13
Joined: Sat Nov 22, 2014 1:12 pm

Sun Nov 17, 2019 4:06 am

I've noticed two issues:
  1. I can't get data from any show by the /series/{id} endpoint.
  2. The functionality of the "banner" field of a series changed.

1. Issue:

I've searched for a show e.g. "Game Of Thrones" and I tried to get data per the resulting ID "121361" with the mentioned endpoint. But I am always getting the following error:
Image

2. Issue:

When I am searching for a series I am getting a poster in the banner field. In the old version I was always getting a banner like that:
Image

Is this intended? And if the banner is missing the field is filled with ""/bannershttps://beta.thetvdb.com/images/missing/movie.jpg".

Image
Post Reply