TV banner is shown on website, but missing in API.

A place for developers to advertise their TheTVDB.com enabled app and get help from other developers with the API.
Freddy12
Posts: 5
Joined: Thu Aug 01, 2019 11:50 pm

TV banner is shown on website, but missing in API.

Postby Freddy12 » Fri Aug 02, 2019 5:33 am

Show:

Code: Select all

https://www.thetvdb.com/series/the-hunting-2019


You can see it has a banner.

API request URL (searching by IMDD ID):

Code: Select all

https://api.thetvdb.com/search/series?imdbId=tt9690214


API response:

Code: Select all

{"data":[{"aliases":[],"banner":"","firstAired":"","id":366420,"network":"SBS (AU)","overview":"The Hunting is about two high school teachers who discover students are sharing nude photos of their underage friends and peers, and the consequence this has on the teens and their families. ","seriesName":"The Hunting","slug":"the-hunting","status":"Continuing"}]}


As you can see the banner is empty in API.

Zappiti
Posts: 1
Joined: Fri Aug 02, 2019 8:32 am

Re: TV banner is shown on website, but missing in API.

Postby Zappiti » Fri Aug 02, 2019 8:41 am

Hello,

We have same problem here.

Call:

Code: Select all

https://api.thetvdb.com/series/73838/images/query?keyType=season


Sample Result:

Code: Select all

{
     "id": 0,
     "keyType": "",
     "subKey": "",
     "fileName": "",
     "languageId": 0,
     "resolution": "",
     "ratingsInfo": {
       "average": 8.9,
       "count": 7
     },
     "thumbnail": "_cache/"
   }


Regards.

jacovis
Posts: 5
Joined: Fri Mar 01, 2019 9:25 pm

Re: TV banner is shown on website, but missing in API.

Postby jacovis » Fri Aug 02, 2019 9:50 am

I have exactly the same problem since today. Confirmed field 'filename' is empty, also when testing using https://api.thetvdb.com/swagger#/

sample

Code: Select all

https://api.thetvdb.com/series/365722/images/query?keyType=poster


response body

Code: Select all

{
  "data": [
    {
      "id": 0,
      "keyType": "",
      "subKey": "",
      "fileName": "",
      "languageId": 0,
      "resolution": "",
      "ratingsInfo": {
        "average": 8.9,
        "count": 7
      },
      "thumbnail": "_cache/"
    },
    {
      "id": 0,
      "keyType": "",
      "subKey": "",
      "fileName": "",
      "languageId": 0,
      "resolution": "",
      "ratingsInfo": {
        "average": 8.9,
        "count": 7
      },
      "thumbnail": "_cache/"
    }
  ]
}

rednoah
Posts: 37
Joined: Sun Jan 04, 2009 3:52 pm

Re: TV banner is shown on website, but missing in API.

Postby rednoah » Sat Aug 03, 2019 2:48 am

Yep, /series/75930/images/query?keyType=poster type requests are basically just empty scaffolding right now.

WindedHero
Posts: 28
Joined: Sat Apr 11, 2015 12:22 pm

Re: TV banner is shown on website, but missing in API.

Postby WindedHero » Sun Aug 04, 2019 2:01 pm

I have complained about the same issue here: viewtopic.php?p=155488#p155488
I have also posted follow up comments.
No comment from anyone. Pervasive API issues/database issues/hosting issues after the rollback, and a "daily update" thread that isn't so daily at: viewtopic.php?f=118&t=57706

Some transparency would be nice.

jacovis
Posts: 5
Joined: Fri Mar 01, 2019 9:25 pm

Re: TV banner is shown on website, but missing in API.

Postby jacovis » Mon Aug 05, 2019 2:37 pm

Seems to be resolved at this time.