Search found 35 matches

by dlflannery
Wed Nov 20, 2019 7:21 am
Forum: Developers
Topic: order of search/series/{name} endpoint results
Replies: 0
Views: 143

order of search/series/{name} endpoint results

The metagenerator app I program (MG3) searches for series using a name (title) string entered by the user. After the switch to the V3 app one user complained that when he searched on 'ruins' MG3 returned multiple series whereas (he claims) the V2 version returned only the series he wanted, which is ...
by dlflannery
Sun Nov 17, 2019 6:17 am
Forum: Developers
Topic: API Access to new site features?
Replies: 1
Views: 506

Re: API Access to new site features?

Same question ............
by dlflannery
Sun Nov 17, 2019 12:56 am
Forum: Developers
Topic: V3 Testing
Replies: 12
Views: 7476

How to access V3 API?

Can someone tell me how to be sure I'm testing the V3 API in the app I program? Here are possible options I've seen on the forum or in the API documentation: 1. Use api-beta.thetvdb.com 2. Put Accept:application/vnd.thetvdb.v$VERSION. in the headers 3. api.thetvdb.com now defaults to V3 Which or wha...
by dlflannery
Thu Nov 14, 2019 11:30 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13520

Re: Issues with the API

However if I use the curl command provided via swagger:

curl -X POST --header 'Content-Type: application/json' --header 'Accept: application/json' -d '{"apikey" : "MYAPIKEY"}' 'https://api.thetvdb.com/login'

preceded by sudo in my Linux pi -- it succeeds!
by dlflannery
Thu Nov 14, 2019 11:11 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13520

Re: Issues with the API

I ran the same curl command preceded by "sudo" in the Linux system on my raspberry pi. The response this time was:

{"Error":"Not authorized"}
by dlflannery
Thu Nov 14, 2019 10:53 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13520

Re: Issues with the API

I'm trying curl with no success so far. If I copy the curl command code you posted into a Win10 command window, substituting my API key, I get this response: {"Error":"Bad Content-Type or charset, expected 'application/json'"}curl: (6) Could not resolve host: application curl: (6) Could not resolve ...
by dlflannery
Thu Nov 14, 2019 8:52 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13520

Re: Issues with the API

C:\Users\Dave>ping api.thetvdb.com

Pinging d28ljkmapxhl0h.cloudfront.net [13.225.224.83] with 32 bytes of data:
by dlflannery
Thu Nov 14, 2019 8:50 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13520

Re: Issues with the API

Correction: It's wreq.GetResponse() that errors out.
by dlflannery
Thu Nov 14, 2019 8:37 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13520

Re: Issues with the API

(I tried to edit this into the previous post. Forum won't let me)

The getRequestStream errors out with the message:
"The underlying connection was closed. An unexpected error occurred on a send:
by dlflannery
Thu Nov 14, 2019 8:30 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13520

Re: Issues with the API

My code doesn't use my credentials, just the API key. Swagger was successful getting token with my API keyl. Here is the snippet of my C# code that gets the token: string jsonStr = "{\"apikey\": \"" + apiKey + "\"}"; UTF8Encoding encoding = new UTF8Encoding(); byte[] byte1 = encoding.GetBytes(jsonSt...