Search found 9 matches

by imthedoctor12
Sun Nov 17, 2019 9:38 am
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13521

Re: Issues with the API

Thank you codegrabber. I was afraid I was doing something wrong. Now I'm more concerned that it's not working correctly on the API side. When I send Accept:application/vnd.thetvdb.v2.2.0 in postman, the response header still indicates it's coming from 3.0.0, which still seems to be having issues fin...
by imthedoctor12
Sat Nov 16, 2019 7:12 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13521

Re: Issues with the API

I'm still unclear how to actually specify the API version using the accept header. Can anyone help me understand?
by imthedoctor12
Thu Nov 14, 2019 11:37 am
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13521

Re: Issues with the API

The links section in the response seems to be having an issue as well. It's always returning "links": { "first": 1, "last": 1, "next": null, "prev": null } even if there are more pages examples from https://api.thetvdb.com/swagger vs https://api-dev.thetvdb.com/swagger curl -X GET --header 'Accept: ...
by imthedoctor12
Thu Nov 14, 2019 11:02 am
Forum: Version 3
Topic: can't login at all
Replies: 23
Views: 2054

Re: can't login at all

Clearing cache did the trick and I was able to get to https://beta.thetvdb.com/dashboard/account/apikeys
by imthedoctor12
Thu Nov 14, 2019 10:51 am
Forum: Developers
Topic: Confusion in setting API version in request
Replies: 0
Views: 652

Confusion in setting API version in request

I'm trying to fall back to an older (specific) version of the API by passing an Accept:application/vnd.thetvdb.v$VERSION as specified in the documentation. However no matter what value I pass in the headers in the response shows the reply coming from X-Thetvdb-Api-Version 3.0.0 In postman I'm settin...
by imthedoctor12
Wed Nov 13, 2019 9:23 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13521

Re: Issues with the API

szsori wrote:
Wed Nov 13, 2019 9:11 pm
Try using just the original API key without the username and user key, and let me know if you still get this error.
Using just the api key I'm able to successfully retrieve a token :)
by imthedoctor12
Wed Nov 13, 2019 9:18 pm
Forum: Version 3
Topic: can't login at all
Replies: 23
Views: 2054

Re: can't login at all

by imthedoctor12
Wed Nov 13, 2019 8:15 pm
Forum: Version 3
Topic: can't login at all
Replies: 23
Views: 2054

Re: can't login at all

I'm in the same boat. I'm getting an error trying to retrieve a token

{
"Error": "Valid User Account Required"
}

I tried generating a new API key and using that I get

{
"Error": "API Key Required"
}
by imthedoctor12
Wed Nov 13, 2019 7:18 pm
Forum: Developers
Topic: Issues with the API
Replies: 59
Views: 13521

Issues with the API

I'm back a 401 unauthorized trying to hit the API (https://api.thetvdb.com) with an error response { "Error": "Valid User Account Required" } Except I've verified the credentials, I even tried generating a new API key, which results in a response of { "Error": "API Key Required" } additionally I'm g...